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1 Introduction

JDisc Discovery's Networking Add-On extends JDisc Discovery's discovery with
network management features, including:

1.

Network Topology Discovery

JDisc Discovery's discovery determines the network (layer 3) and segmentation
(layer 2) topology. Network topology (layer 3) describes how routers connect
networks and Segmentation topology (layer 2) describes how switches connect
to other switches and devices within a sub-network.

. Router and Switch Configuration Backup

JDisc Discovery's discovery collects configuration files from Cisco routers,
switches, and firewalls and from HP ProCurve switches. The predefined set of
configuration commands for Cisco and HP ProCurve devices helps you to start
quickly without extra configuration steps. Of course, you can add extra
configuration commands as you need them.

JDisc Discovery keeps a history of configuration files and provides a comparison
feature to spot the differences between revisions.

Enhanced Router and Switch Discovery
The Networking Add-On augments JDisc Discovery's discovery to also discover
modules of many interconnect devices.

VLAN Discovery
With the Networking Add-On, JDisc Discovery detects VLANs and their
associated switch ports for many network switches.

WLAN Discovery

JDisc Discovery's WLAN discovery identifies WLANs and access points in the
proximity of Windows and Mac OS X computers. WLANS, access points and
WLAN clients are also displayed in segmentation topology maps.



2 Network Topology

The network topology section provides some background information on network
topology and the OSI networking model before explaining how JDisc Discovery
determines the network and segmentation topology.

2.1 Background

A network topology defines interconnections between devices on a computer network.
Topologies can be logical or physical. Logical topologies explain the data flow within the
network whereas the physical topology describes the actual cable connections
between elements.

The OSI layer sub-divides a communication system into seven layers:
Physical Layer

Data Link Layer

Network Layer

Transport Layer

Session Layer

2R o

Presentation Layer
7. Application Layer

Each layer provides specific services for the higher level layers and makes use of the
lower level layers.

2.1.1 Data Link Layer

The data link layer and the network layer are the most important.

According to Wikipedia, the data link layer 'provides the functional and procedural
means to transfer data between network entities and to detect and possibly correct
errors that may occur in the Physical Layer'. Switches and bridges operate on network
layer two.

Switches connect devices within a network and prevent collisions among devices within
one network. In most networks, switches are connected to other switches to either
provide redundant communication paths or to connect more devices to the network.



Diagram: Two switches connecting devices

The above diagram shows two switches connecting PCs, laptops, printers, and servers
within a network. Each device is connected to one switch port.

W Switches operate on the OSI layer 2 and connect devices within a
network.

2.1.2 Network Layer

Wikipedia defines the network layer as a layer that 'provides functional and procedural
means of transferring variable length data sequences from a source to a destination via
one or more networks, while maintaining the quality of service requested by the
Transport Layer. The Network Layer performs network routing functions, and might also
perform fragmentation and reassembly, and report delivery errors. Routers operate at
this layer .

The following diagram illustrates how two routers connect three networks. Since routers
work on layer 3, we call this the layer three or network topology.
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Diagram: Routers connecting IP networks

1. Routers operate on the OSI layer 3 and connect different networks.

2.2 Network Topology Discovery

This section explains how JDisc Discovery discovers the network topology and what to
consider to achieve good results.

2.2.1 Interface Status

The status of a network interface is described by the two status values below:

1. Administrative Status:
When a network administrator enables a network interface, it is considered
administratively 'up'. Otherwise, it is considered administratively 'down’.

2. Operational Status:
The operational status indicates whether a network interface is connected to an
active devices. When the operational status is 'down’, either no device is
connected or the connected device is switched off.



2.2.2 Requirements

SNMP read access to all routers and switches is absolutely important. Moreover, JDisc
Discovery queries variables of three SNMP MIBs (CISCO CDP, MIB LLDP MIB and the
Bridge-MIB) when discovering routers and switches.

Routers and switches exchange link neighbor information via CDP (Cisco Discovery
Protocol) or LLDP (Link Layer Discovery Protocol). JDisc Discovery can use CDP and
LLDP information to create interconnections between routers and switches. Please
note: The completeness of the segmentation topology is depending on the support of
the CDP or LLDP protocols of all switches within a sub-network.

In addition to CDP and LLDP, JDisc Discovery queries the MAC forwarding tables from
switches to create the segmentation topology when CDP or LLDP are not available.
LLDP, CDP and port forwarding can be enabled globally and for individual devices.

The connections between switches and endpoint devices (all device other than routers
or switches) are based on the address forwarding tables (exposed by the Bridge-MIB)
of each switch port. Switches store the sender MAC addresses of link layer packets
received on each switch port in a cache. Unfortunately switches discard address
forwarding information of devices that do no longer send link layer packets for a certain
time period (default is 5 minutes). Therefore, JDisc Discovery keeps the switch port
connections until either the device has been connected to another switch port or
another device is connected to a switch port.

You can schedule JDisc Discovery's discovery to regularly collect segment topology
data for each sub-network (default is 15 minutes).

| 1. Unmanaged switches cannot be mapped in the
e segmentation topology. Such switches are even invisible to
the network discovery and have a negative impact on the
accuracy of the segmentation topology.

2. Switches and routers must support Cisco's CDP MIB, the
LLDP MIB or the Bridge-MIB. If not, JDisc Discovery cannot
determine the interconnections between routers and
switches.

3. Make sure CDP or LLDP are enabled on your routers and
switches if you enable those protocols in the topology
settings.

4. Switches must support the Bridge-MIB (RFC 1493) to create
the mapping of end-point devices to switch ports.

5. When a switch port is operational down, it is not possible to
detect if no device is connected or if a previously connected
devices has been turned off. In this case, JDisc Discovery
keeps the last connection.
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2.2.3 Topology Configuration

There is nothing in particular to configure for the network topology discovery. Whenever
JDisc Discovery detects a switch, then it reads the port forwarding, CDP and LLDP
information (if available). Based on this information, JDisc Discovery detects the
network topology.

2.2.4 Topology Pitfalls

Although topology information is available via CDP, LLDP and mac forwarding
information, the result might not always be perfect. There are several reasons for this.
Especially, when you mix devices from multiple vendors supporting different protocols.

So let's suppose we have three switches (Switch A, Switch B and Switch C). Switch A,
Port 1 is connected to Switch B, Port 1. Switch B, Port 2 is connected to Switch C, Port
1.

Switch A and C have CDP configured, Switch B does not support CDP.

Port 1 | Purtll

[ Port 2 Port 1!
Switch A Switch B Switch C
CDP Supported Mo CDP Supported CDP Supported

Figure: Simply Switch Topology

Since Switch B does not reply to CDP requests, Switch A thinks that it is directly
connected to Switch C. When JDisc Discovery reads CDP information from Switches A
and C, then it gets incomplete information that those two switches are directly
connected. Switch B is not visible because it is not supporting CDP.

In combination with LLDP, it might even be more complex. LLDP and CDP information
might provide different connections due to supported or not supported protocols on the
switches.

Whenever you know, that CDP or LLDP information for a switch is incomplete or not
correct, then you can disable CDP or LLDP for individual switches using the context
menu Manage > Disable Discovery Protocols.

2.3 Review MAC Forwarding, CDP And LLDP Information

JDisc Discovery stores the mac forwarding, CDP and LLDP information in its database.
Each switch can display the stored information within its device properties.

- 11 -



2.3.1 MAC Forwarding Table

Each switch maintains a set of mac addresses that visible on a switch port. When there
is exactly one network interface attached to the switch port, then the set includes
exactly one mac address. When there are multiple devices visible from the switch port
(e.g. because the port is connected to another switch which contains the actual
devices), then it might contain multiple mac addresses.

aaaaaaa

aaaaa

46
15056
152056

192.188.178.13%
192.168.178.13%

Total 57MAC forwerding enres | 1 MAC forwarding enty seected

Figure: Port Forwarding Table

The port forwarding table contains information about the local switch interface and
information about the remote mac address. When the device that belongs to the remote
mac address has been scanned correctly, then the report also displays information
about the remote device.

2.3.2 CDP Table

CDP (Cisco Discovery Protocol) is a Cisco proprietary protocol that is used by Cisco
switches to determine the switch to switch connections. But there are also other
vendors that licensed this protocol.

Desarption locslindex  Remotelndex  RemoteDeviceDescrpton  Remote Descripton Remote Addess  Remote Name Remote Manufacturer Remote odel Renote Type
B

Total . COP entry |0 CDP entresselected
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Figure: CDP Table

2.3.3 LLDP Table

The purpose of the LLDP (Link Layer Discovery Protocol) is similar to the CDP
protocol: Detect switch to switch connections. However this is an open standard and no
proprietary protocol. So many vendors support this protocol.

Physcal address  Type Desarption LocalIndex  Remoe Index = [ RemoteAddress  RemoteName  RemoteManufoctrsr RemoteModd  Amofaton  Remot]

ccccc

Figure: LLDP Table

2.4 Network Topology Views

JDisc Discovery stores topology information in its database and provides graphical and
report based topology views.

2.4.1 Graphical Representation

JDisc Discovery can create network maps that visualize the network topology. Two
different kinds of networks maps exist:

1. Network maps that display how routers connect networks (Layer 3 map).

2. Segment maps that display how devices are connected to each other within a
network (Layer 2 map).

Objects in a map can have actions associated with its icon. Select an object in a map
and open the context menu to review available actions.

Maps can be expgrted as JPG image. You can use the File » Save as JPG... or click
the camera icon & to save the map as image.

Save the current map layout either with with File » Save or click the disc icon =, saved
maps are available from Maps » Topology Maps.
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Use the magnifying glass icons (% and ‘=) to zoom the map in or out.
Use the enlarge « » and the shrink = = button to enlarge or shrink the canvas.

When a map is created, JDisc Discovery automatically creates a layout. The layout
depends on the selected algorithm and the network topology. JDisc Discovery Offers
five different layout algorithms.

The Filters menu allows removing devices of a specific device types from the map. You
can also use the Remove context menu to remove selected devices from a map.

2.4.1.1 Network Maps (Layer 3 Maps)

Open the IP4 network report from Networking » IPv4 Networks. Select networks to
include into the network map, open the context menu and select Network Topology.

The following figure shows a network topology consisting of 5 networks and 2 routers
connecting the networks.

D New Topology Map ‘ =HAC] -?Eu—]

File Layout View Filter

& \ZI Lj]l 4 & | e Rt | 1 show WLANSI V| Enable connection hop limit 115 hops

921681230 92.168.178.0
255.255.255.0 255.255.255.0

rir1.tesicormpany.com

92.168.111.0
255.255.255.0.
 tray

o —
rirtestcompany N
92.168.110.0 92.168.154.0
255.255 266.0 255.255.256.0

Figure: Network topology

When you double-click a network the segment topology map of the selected network
opens. The segment topology map is associated to its network map. When you save a
segment map the associated network map is also saved. All layout changes are stored
in the database.

2.4.1.2 Segment Maps (Layer 2 Maps)

Segment maps (also called layer 2 maps) display how devices are connected to each
other. You can open segment maps in three different ways:

1. Double-click a network in a network map. This opens the network's segment
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topology map.

. Open the IP4 networks report (Networking » IPv4 Networks) and select a
network. Open the context menu and select Segment Topology » All Devices or
Segment Topology » Network Devices Only. The all devices options opens a
map including all devices having topology connections. The network devices
only options opens a map that only includes routers and switches having
topology connections.
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7 y
1D 1Pvd Networks = | 5 i)
™ & |0 @ E 2
Gl==2QREBDG 6|
Filter:
[] Case sensitive filter
Netwark AddrE;s Subnet Mask Name Device Count % De
0.0.0.0 255.0.0.0 il -
12.0.0.0 255.0.0.0 34 F
12.14.0.0 255.255.0.0 il
12.119.0.0 255.255.0.0 3
12.216.104.0 255.255.252.0 76
12.230.170.0 255,255,255.0 1
12.249.108.0 255.255.255.0 1
12.251.240.0 255.255.255.0 78
12.255.136.0 255.255.255.0 12
15.0.0.0 255.0.0.0 1 :
17.0.0.0 255.0,0.0 1 3
23.0.0.0 255.0.0.0 2
652.0.0.0 255.0.0.0 2
55.0.0.0 255.0.0.0 1
79.0.0.0 255.0.0.0 1
122.0.0.0 255.0.0.0 1
157.55.0.0 255.255.0.0 1
157.56.0.0 255.255.0.0 1
169.254.0.0 255.255.0.0 0 i
173.194.0.0 255.255.0.0 3
192.168.0.0 255.255.0.0 1
192. 168, 180. 255.255.255.0 Devices 4
192, 168.181.0 255,255,255.0 Dicger » I8
ol Ul Router/Switch Ports | L
Total 30 IPv4 networks | 1 IPv4 network selected n% Network Topology
Segment Topology ! uzy  All [?Ig&rlces
L L] OpenTopologyleg |.m MNetwbrk Devices Only

Figure: Open a network topology map

3. Open a segment topology map from a device report. Select one or multiple
devices (so called root devices), open the context menu and select Create
Topology Map.
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D All Devices = | 5 i)
B ==28DBE G0

Filter:
[] Case sensitive filter
Name: ° 1P Address Manufacturer Model
SUMMITS. 192,108, 18L.5 EXTEME NETWOTKS SUMMIT <1 L
SunvirtualBoxInstance-1 12.251.240.97
Switch-1 12.216.107.24 Nortel Networks Nortel GbE Switch Module
Switch-10 12,251.240.219 Hewlett-Packard ProCurve 2524
Switch-11 12,251.240.107 Hewlett-Packard ProCurve 2524
Switch-2 12.216.106.203 Nortel Networks Nortel GhE Switch Module
Switch-3 12.216.105.210 Nortel Networks Nortel GhE Switch Module
Smbd'l 4 12 216 104.37 Nortel Networks Nurte\ GbE Smbd'l IModule
M".'_'-'—__
B Properies L JProCurvedsas |
Smh:h-s 12 251 2 B come » ProCurve 2626
Switch-2 12.251.2 ProCurve 2524
teetee-pc. fritz.box 192,168, Manage L m&180.de
tomaptop3. fritz.box 192,168, Histoty v MacBookPro10,1
Toms-iPad. fritz.box 192.168.
tirenz-PC2. fritz.box 192.168. Compare r Studio Hybrid 140g
UnknownDevice-1 12.216.1
T s e 12.216.1 Custom Attributes 4
UnknownDevice-3 12.216.1 Connect with v 1]
UnknownDevice-4 12.216.1 W
VMwarelnstance-1 12.216.1 Troubleshoot i
‘MwareInstance-10 12.216.1 Delete Devices...
VMwareInstance-11 12.218.1
VMv‘«areInstanoele ) 12.216.1 i3 Creste Dependency Map... S
< T B 3
Total 335 devices | 4 devices selected £l \Cieste TUPUIUQWEP"‘
l Create Support Z1P
Close
\

Figure: Open a topology map based on selected root devices

A new segment topology map appears displaying the selected root devices and all
directly connected devices. Root devices are highlighted with blue background. You
can increase the hop count to display more devices that are indirectly connected to the
root devices.
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D New Topology Map

File Layout View Filter
[=F] a @l 4 &Y ‘ u: an asu |[F]Show WLANS“ZE Enable connection hop limit 144 hops

i » £
li li |
i i
Switch-2 ckServer-5

Switch-7

I

Switch-11

vww

Unménaged Switch
Hub

li ﬂemenmewce-ﬂ
i

Switch-6

m,

I .

Switch-9
RackServer-2

RackServer-3

Figure: Segment Topology based on root devices

2.4.2 Topology Reports

In addition the network and segment maps, the Networking Add-On augments JDisc
Discovery with several new reports and menus. This section explains the new menu

items.
2.4.2.1 Enhanced Interfaces Report
The device interface report contains a second table displaying devices that are

connected to selected interfaces. You can select one or more interfaces to view what
devices are connect to selected interfaces.
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O Device Detals for ‘Switch-& = | B oS
l==2/ah8n0 8 ulxE
General‘ Networking ‘ Hardware | Firmware I Software | User | Connections | Virtual Computers | Custom Attributes I Roles I Groups I Analyzel
Interfaces | yLANS | WLANs | WLAN Access Paints | Networks | SNMP System Group|
Interfaces
Filter:
[] Case sensitive filter
Port Physical Address Type

1 00:12:79:da:83:a8 ethernetCemacd -

U I (Y P
3 00:12:79:b0:33:3c ethernetCsmacd E
4 00:12:79:ad:05:9b ethernetCsmacd
5 00:12:79:7f:b5:91 ethernetCemacd
& 00:12:79:5f:5d:d1 ethernetCsmacd
7 00:12:79:33:c1:28 ethernetCsmacd
8 00:12:79:19:8e:37 ethernetCsmacd
9 00:12:79: 1a:66: 2f ethernetCsmacd
10 00:12:79:e3:5e:86 ethernetCemacd -

b I r
Total 30 interfaces | 1 interface selected
Connected Devices
>
Description Name IP Address Manufacturer Model
1lano RackServer-5 12.251.240.16 Hewlett-Packard rx2660
] m 3
Total 1 device | 0 devices selected
Close

Figure: Enhanced Interface Report

2.4.2.2 Routing Device Report

The routing devices report displays all routing devices. Select Networking » Topology »
Routing Devices.

2.4.2.3 Router/Switch Ports Report

The Router/Switch Ports report displays all routers and switches including the number
of available and used ports. When the operational status is down, either a connected
device is turned off or the port is enabled, but not device is connected. It is not possible
to determine the correct state. Therefore JDisc Discovery introduces two more port
states:

1. Potentially used:
A port is potentially used when the administrative status is up, the operational
status is down and the topology discovery has detected a device connected to
that port in one of the previous runs. JDisc Discovery assumes the device is still
connected, but turned off. The aging mechanism will delete this device
connection automatically when the device is not turned on for a specified
interval.

2. Potentially free:
A port is potentially free when the administrative status is up, the operational
status is down and the topology has not detected any device connected to this
port in one of the previous runs.
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2.4.2.4 Custom Reports

Network topology information is also available for use with custom reports. The figure
below illustrates the new topology fields in the Networking sub-tree.
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1D Add User Group Custom Report =)
Main Interface -
1P4 Addresses Remote Device Name =
‘Main TP4 Address
[#H-etwork Neighborhood Add Tz
WLAN
WLAN Access Points 3
Loadbalancer Pocls Conditions (Connected with OR)
SNMP Agent
Connections
[=}-Topology
[=-Metwork Topology Details
[] Local Index
- [[] Local Physical Address
- [[] Local Type
[] Local Description
[] Local Speed =
‘B
- [] Remote Device IP4
[7] Remote Device Type
- [ Remote Device Model
- [[] Remote Device Manufz
[ Remote Device Serial Iy
[] Remote Index
- [C] Remote Physical Addre|
- [7] Remote Type
[7| Remote Description |
[C] Remote Speed
-Switch Port Farwarding
User < Total 0 conditions | @ conditions selected
[ | r
[ Back ] [ Next ] [ Finish ] [ Cancel

Figure: Custom reports displaying topology information

2.4.2.5 Saved Maps

Maps » Topology Maps displays all saved topology maps. Open a saved map using a
double-click on the map's name.
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3 Configuration Backup

JDisc Discovery already collects files, system command and custom script output. The
Networking Add-On extends JDisc Discovery's remote login and data collection
capabilities to include Cisco and HP networking devices. JDisc Discovery supports
these products:

e Cisco devices running I0OS
e Cisco PIX and ASA firewalls
e HP ProCurve switches

The set of supported devices will be extended in future releases.

3.1 Configuration

This section explains how to enable configuration file collection for network devices. As
for Unix computers, JDisc Discovery logs on to devices using telnet or SSH' and
executes commands to retrieve configuration files.

Device must have been identified via SNMP to determine what commands to execute.
If SNMP read access has failed, JDisc Discovery cannot collect configuration files even
if access credentials for Telnet or SSH have been provided.

W To collect configuration files of networking devices SNMP read
® access is required.

1 Note that SSH1 is not supported!
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3.1.1 Enable Remote Login

Open the Discovery Configuration dialog from Discovery » Configuration and select
the Protocols tab. Click Interconnect Devices next to the Clients & Servers tab.

D Discovery Configuration @

‘ General I Scope I Directory | Data Collection I Discovery Jobs| Protocols | Topology Jobs I Filters | S5H Keys

Discovery Protocols

Ping 2000 - miliseconds | 2 5 |retries
[¥]DNs 2000 - miliseconds | 2 - retries
[F] SMMP (v1fv2efv3) 2000 |5 miliseconds | 25 |retries
[¥] NetBIOS 10 - seconds
[¥] 5MB (Server Message Block) 120 5 seconds

WMI (Windows Management Instrumentation) | 120 | seconds

WBEM (Web Based Enterprise Management) 10 -5 | seconds
Telnet banner parsing 7000 |2 miliseconds Store unknown telnet banners in database
[¥] HTTP based identification 3000 = miliseconds
[¥] HTTPS based identification 5000 - milliseconds
VMware VIM APT 120 |5 seconds
Remote Login

Windows | Unix & VMware | Interconnect Devices

Platform Remote login method Connect timeout Execute timeout

Cisco 10S Remote login disabled ~ | 2 | minute(s) 15 | minute(s)
Cisco PIX 05 |Use telnet only -: 2 | minute(s) 15 - | minute(s)
Cisco ASA Remote login disabled - 2 minute(s) 15 minute(s)
HP ProCurve |Remote login disabled 2 || minute(s) 15 | minute(s)

Enable remote login for interconnect devices

Choose the remote login method and timeouts for the desired platform as appropriate
and click Ok to save the configuration.
3.1.2 Provide Access Credentials

To collect configuration information, JDisc Discovery needs access credentials to log on
to interconnect devices, such as routers or switches. Open the discovery configuration
dialog with Discovery » Configuration and select the Accounts tab from within the
Scope tab.
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D Discovery Configuration @
‘ General‘ Scope | Directory | Data Collection I Discovery Jobs I Protocols |Tup0|0gy Jobs I Filters | S5H Keys‘
=
[\, EMEA | Properties | Device History I IPv4 Networks I IPv4 Ranges | IPv6 Networks I Network Neighborhood I Directory | SNMPl Accounts L
Use default accounts from all platforms for unknown devices
Clients & Servers | Interconnect Devices
[ cisco 105 | Cisco P1X 05 | Cisco AsA [ 1P Procurve
Cisco PIX OS Accounts
User name Password Type Add k
I [renove._]
(=) root/enable
Mave up
Total 2 Accounts | 1 Account selected
Cisco PIX OS5 55H Public/Private Keys
Key name User name Key type Passphrase  Type Add
Remove
< [ n . *
Total 0 55H public/private keys | 0 55H public/private keys selected

Figure: Enter default accounts for interconnect devices

JDisc Discovery only uses the non-privileged user account to log on to interconnect
devices. The enable user account is only used when switch to enable mode is needed.

% When an interconnect device only use password authentication,
leave the login field empty.

If an interconnect device does not have a enable password, add an
empty enable account without login and password. Otherwise,
JDisc Discovery does not switch to enable mode.

3.1.3 Configure File Collection

JDisc Discovery comes with a predefined set of file collections for supported
interconnect devices. Open the Discovery Configuration dialog from Discovery »
Configuration and select the File Collection sub-tab within the Data Collection tab.

Check or uncheck the check box to enable or disable the desired file collection. Click
Add to add new data collections.
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.
) Add Cisco PIX OS File Collection gt
History

[¥] Keep change history for at least 90 5| days

File Collection

Collection name Show Tech Support

Collection command | show tech

Cancel

Figure: Add a new file collection for Cisco IOS devices

JDisc Discovery captures and collects the command output when the device is
discovered the next time. You can view the result of the new file collection as any other
custom attribute. Refer to the discovery manual for more information about custom
attributes.
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4 VLAN Discovery

JDisc Discovery's Networking Add-On identifies the VLAN configuration of the most
popular switches. For Cisco Switches, JDisc Discovery reads private Cisco MIB
information and the Bridge-mib for all other switch manufacturers. VLAN information
can be displayed globally or for each switch individually.

4.1 Concepts

VLANSs partition layer 2 networks into multiple collision domains or help to create
multiple layer 3 networks on a single switch.

Static VLANSs consists of a fixed switch port configuration all belonging to the same
VLAN. Tagged VLANs embed VLAN membership information (tags) into network
packets which are used by switches to forward network packets to the designated
ports.

VLANSs are identified by ids and administrators can assign friendly names to VLANs (for
instance 'Test Environment' for VLAN id 10) when configuring their switches. Assigning
consistent friendly names for each VLAN on the network greatly simplifies the
administration and troubleshooting. Unfortunately VLAN friendly names are not always
assigned consistently over the network.

In order to cover both cases, JDisc Discovery lets the administrators define how to
identify VLANS:

Identify a VLAN based on the VLAN tag id only
Identify a VLAN based on the VLAN tag id and the friendly name
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You can choose this option in the Data Collection » Networking tab

D Discovery Configuration @

General I Scope I Directory | Data Collection | Discovery Jobs I Protocols | Topology Jobs I Filters | 55H Keys
Standard | Custom | File Collection

User
Discover users

Ignore Built-n and service users

Delete users from logged on user history when not logged on for 30 & day(s)
Find terminal services dients

[] Discover terminal services dients

Software/Hardware /MNetworking

Discover applications Discover executable fles &) Discover disks Discover attached devices

Discover licenses Discover processor Discover virtual instances Discover monitors
Discover patches Discover memary Discover blade endosure compon... iscover local printersy...
Discover services Discover video controllers Discover managed devices Discover local scanner
Discover drivers Discover duster Digcover VMware annotations Discover card reader
Discover processes Discover wlans (&)

Use pargs on Sol... ) Identify VLANs by VLA id only. -
VLAN id only k
Dependercy Meppig

Find dependendies between computers
|| Discover connected devices

[ Delete inactive dependencies between computers when older than 7 = day(s)

Fig: Configuration of the VLAN Identification

4.2 Device VLAN Information

The Device Details » Interfaces report displays VLAN membership information of each
switch interface.
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D Device Details for 'ProCurvel’ B )
$l==2aDHLDWGE|&E
Networking | Hardware | Firmware | Software | User | Connections | Virtual Computers | Custom Attributes | Roles | Groups | Analyze|
[Interfaces | VLANs | wians | wiaN Access Points | Networks [ s system Group|
Filter
|| Case sensitive filter
VLANI | Name Part Physical Address Type Desription Speed ‘Admin Status Oper. Status
ethernetCsmacd 37 100,00 MBit/sUp Don B
ethernetCsmacd 38 10000 MEit/s Up. Down
ethernetCsmacd 33 100.00 Mit/sUp Up
ethernetCsmacd 40 10000 MEit/s Up. Down
ethernetCsmacd “ 100.00 Mit/sUp Donn
ethernetCsmacd 42 10000 MEit/s Up. Down
ethernetCsmacd 3 100.00 Mit/sUp Donn
ethernetCsmacd 4“4 10000 MEit/s Up. Down
ethernetCsmacd 45 100.00 Mit/sUp Donn
ethernetCsmacd 46 10000 MEit/s Up. Down
ethernetCsmacd 47 100.00 Mit/sUp Donn
ethernetCsmacd 42 100,00 MEit/s Up. Down -
ethernetCsmacd 1.00 GAit/sUp
ethern: cd
Total 2 vians | 1 vian selected

Figure: Device VLAN Report

The device VLAN report lists all VLANs and the corresponding ports.

4.3 VLAN Report

The VLANSs reports displays VLANs along with the number of switches that are
member of the VLAN. Select Networking » VLANSs to display the VLANSs report.

(3 vians [E=ER)
-=Z |8 ha0 o

Filter:

[ Case sensitive filter

7
WLAN Id Name Device Count

1 DEFAULT_VLAN
50 Client Test
200 Testservers2
400 vlan2
4,094 netl

[SRNINIe. ¥

Total 5 VLANSs | 0 VLANs selected

Figure: VLANs Report
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Double-click a VLAN to open a new VLAN Switch Port report displaying all switch ports
that belong to the selected VLAN.
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I3 VLAN Switch Ports belonging to VLAN 'L [DEFAULT_VLAN]'

==2|8|h/BD|G U]
Fier
[] Case sensitive filter
Name 1P Address Monufacturer  Model Type  OSVesin  SerialNumber  Ifindex Port IfDescripton IFType I Speed I Admin Status1f Oper Status
# 25FastEtemet0/13 ethemetCamacd 08itfsUp Down .
15 26FastEthernetn/14 ethernetCsmacd 0 BitfsUp Down
b 27FastEthemet0/15 ethernetCamacd 08itfsUp Down
17 28FastEtemet0]16 ethemetCamacd 100,00 MBit/sUp U
ProCurvel 192168,178.18  HewettPadard ProCurve 2650 Swith  H.08.72 TVISHSDIBU 2 22 ethemetCsmacd 100,00 MEit/sLp Down
3 33 ethernetCamacd 100,00 MBitfsLp Down
4 44 ethemetCamacd 100,00 MBitfsUp Down u
5 55 ethemetCsmacd 100.00 MBit/sUp Down ;|
6 66 ethernetCamacd 100,00 MBitfsUp Down i/
7 77 ethemetCsmacd 100,00 MBit/sUp Down
8 38 ethernetCamacd 100,00 MBit/sUp Down
9 99 ethemetCamacd 100,00 MBitfsLUp Down
bUJ 010 ethemetCsmacd 100,00 MBit/s Up Down
11 1111 ethernetCamacd 100,00 MBit/sLp Down
2 pestl ethemetCamacd 100,00 MBit/sUp Down
BEd 1313 ethemetCsmacd 100,00 MBit/s Up Down
# 14 ethernetCamacd 100,00 MBitfsLp Down
15 1515 ethemetCamacd 100,00 MBitfsUp Down
1 1616 ethemetCamacd 100,00 MEit/sLp Down
17 717 ethernetCamacd 100,00 MBitfsLp Down
B 1818 ethemetCsmacd 100,00 MBit/sUp Down
8 81 ethernetCamacd 100,00 MBit/sUp Down
0 020 ethernetCamacd 100,00 MBitfsUp Down
2 221 ethemetCamacd 10000 MEit/sLp Down
2 222 ethernetCamacd 100,00 MBit/sUp Down
2 2323 ethemetCamacd 100,00 MBit/sUp Down v

<

Total 6 Devices | 0 Devices selected

Figure: VLAN Switch Port Report
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4.4 VLANs In Custom Reports

To create custom reports that display switch port VLAN membership, select and add
the VLAN attribute from Interfaces.

- .
D Add Global Custom Report [

Hardware -

[2)-Networking VLANs =
[HInterfaces u

- (] If Index

Add Remove
Port

If Type
If Address
If Speed

Conditions (Connected with OR)

m

If Admin Status

Duplex Mode

If Description -

Annotation

Module Model

Module Description
- [] Module Serial Number

-Main Interface

-1P4 Addresses

-Main TP4 Addre:

If Ot Status ‘

0l e

Total 0 conditions | 0 conditions selected

[ Back ][ Next ][ Finish ][ Cancel

Figure: VLAN Membership Custom Reports
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5 WLAN Discovery

5.1 Wireless LAN Discovery

JDisc Discovery's wireless network discovery utilizes Windows and Mac OS X
computers having IEEE 802.11 compatible network adapters as discovery probe to
capture WLANSs within range.

! I.' - L ;]
Site A- WLAN A Site B- WLANB /\J> I
<> Company SMB2

Corporation ACME Central Site

Fig: WLAN discovery

The above figure illustrates how the two WLANs A and B are discovered from the
central site when the Windows computers in site A and B are being discovered. The
WLANSs and access points of company SMB1 and SMB2 might also show up in the
discovery results depending on the signal strength even though these do not belong to
corporation ACME.

JDisc Discovery's wireless network discovery detects for each Windows or Mac OS X
computer having a IEEE 802.11 compatible network adapter:

Wireless networks within range
Wireless network access points serving the WLANSs in range
Active WLAN connection
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W The remote login protocol for Windows and Mac OS X must be
enabled to discover WLAN information.

5.2 Configuring WLAN Discovery

The configuration of the WLAN discovery is accessible from Data Collection »
Networking.

[ Discovery Configuration
General Scope Directory DatﬁCUHECUUH Discovery Jobs  Protocols  Topology Jobs  Filters Cloud  S5H Keys
Standard Metworking  virtualization Exrhange Server Database SupportEntitements Custom  File Collection

Discover ISCSI initiators and targets

Discover WLANs &)
Discover anonymous WLANs (WLANs without a S51D)
[[] Detect reachable WLANs (might be any public or other WLAN reachable from a device)

WLAM white list pattern

Filter: Add
[[] case sensitive filter Browse
~
Pattern Pattern Type
Apply Pattern

Total 0 Patterns | 0 Patterns selected

VLANs
Identify VLANs by

(®) VLAN id only
() VLAN id and name

Ok Cancel

Fig: WLAN Configuration

The discovery of WLANs can be completely turned off by the checkbox Discover
WLANSs. If there are anonymous WLANs (WLANs without a SSID) in the network then
the discovery of these can be turned off by the second checkbox Discover anonymous
WLANSs.

The option Detect reachable WLANs (might be any public or other WLAN reachable
from a device) determines whether all reachable WLANs should be detected. This
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option is disabled by default and only adds WLANs which a device is connected to.

Control the set of WLANSs that get into your database with a whitelist. WLANs only get
added to the JDisc Discovery's database if an entry in the white list matches the
WLAN's SSID. An empty whitelist adds all discovered WLANSs to the database.

5.2.1 Add An Entry To The Whitelist

D Discovery Configuration
General | Scope | Directory | Data Collection | Discovery Jobs | Protocols | Topology Jobs | Filters | 55H Keys
Standard | Networking | virtualization | Exchange Server | Database | Support Entitlements | Custom | File Callection
Discover WLANS &)

Discover anonymous WLANs (WLANs without a S5ID)

WLAN white list pattern

Filter: A
[[] Case sensitive filter Browse

7~ Change

Pattern Pattern Type I
Remave

Apply Pattern

WLAN White List Pattern Select WLAN As Pattern
Enter a pattern for WLANs that should be discovered Filter:
or select a WLAN as pattern from the Discovered WLAN table. [ Case sensitive filter
\ Discovered WLANs
. HITRON-E320
(®) Match as exact text
Total 0 Patterns | O F - KAIWIZ270
(") Match as simple pattern (* and ? are wildcards) WLAN-6F3441
~ Match I 3 WLAN-B11D34
(_) Match pattern as regular expression \WLAN-868238
VLANs
Identify VLANSs by
(@) VLAN id only
() VLAN id and nam
Ok Cancel

Fig: Add an entry to the WLAN whitelist

Enter a pattern into the text field on the left. A pattern can be:
- asimple text which matches exactly one WLAN SSID
- atext with * and ? as wildcards
- or aregular expression (defined like in the Java programming language)

For convenience there is a list with already discovered WLAN SSIDs. Select an item in
the list in order to copy the content to the filter field.

The Browse opens the list of already discovered WLANS.
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D Discovery Configuration
General | Scope | Directory | Data Collection | Discovery Jobs | Protacols | Topology Jobs | Filters | SSH Keys
Standard | Networking | virtualization | Exchange Server | Database | Support Entitlements | Custom | File Collection
Discover WLANs &)

Discover anonymous WLANs (WLANs without a SSID)
WLAM white list pattern

Filter:

Add

[[] Case sensitive filter Brow:
Pattern Pattern Type Change
Remave

Select WLANs used as white list patterns

Filter:
[[] Case sensitive filter

WLANs to delete
HITRON-E320
KAIWIZ270
WLAN-6F2441
WLAN-B11D34
WLAN-BE8238

Total 0 Patterns | 0 Patterns selected

WLANs
Identify YLANs by

(®) VLAN id only

() VLAN id and name

Total 5 WLAN SSIDs | 0 WLAN SSIDs selected

Ok Cancel

Ok C

Fig: Browse already discovered WLANs

Select one or more entries in order to add them to the whitelist.

Use the Change or Remove buttons to change or remove entries from the whitelist.

5.2.2 Cleanup Already Discovered WLANs

If there are many unwanted WLANSs in the JDisc Discovery's database, they can be
cleaned up with the new white list.
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b} Discovery Configuration
General | Scope | Directory | Data Collection | Discovery Jobs | Protocols | Topology Jobs | Filters | SSH Keys
Standard | Networking | Virtualization | Exchange Server | Database | Support Entitlements | Custom | File Collection
Discover WLANs &)

Discover anonymous WLANs (WLANs without a 55ID)

WLAN white list pattern

Filter: Add

[] Case sensitive filter F—

=
Pattern Pattern Type
~[1= RegEx Remove
Enterprise™ Simple
HITRON-E320 Text Apoly F‘Eétern
WLAN-E11D84 Text
] Delete WLANs

The following 3 WLANs will be deleted from the database:
=
WLANs to delets

KATWI7270
WLAN-6F3441
WLAN-B58238

Total 4 Patterns | 0 Patterns selected

WLANs
Identify VLANs by

(®) VLAN id only

() WLAN id and name

Delete Cancel

Ok Cancel

Fig: Cleanup unwanted WLANs

After pressing the Apply Pattern button a list pops up with WLAN SSIDs that do not
match any of the whitelist entries. There might be empty lines in case there are
anonymous WLANSs in the database. Review the list of WLANs that are to be deleted.
Applying the filter also deletes WLAN accesspoints connected to the shown SSIDs if

they have no IP address.

5.3 WLANSs Report

The WLANSs overview report displays wireless networks within the range of discovered

Windows computers and statistical information including
- Average signal quality of Windows and Mac OS X computers within range
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- Average connection speed of computers having a WLAN connection

The WLAN overview report is accessible from Networking » WLAN » WLANS.

D WLANs = | B[
#le=2/8hIBBIG|E|&

Filter:

(] Case sensitive filter

ssid Type Physical Type Auth, Algorithm Cipher Algorithm Receiving Device Count  Connected Device Count @ Receive Speed ¢ Transmit Speed o Signal Quality [%] o signal Quality [dBm]
Disc Infrastructure IEEE 802 1in wPA2Persanal  CCMP 2 1 19400 MBS 144,00 MBit/s 57.00% 2
Disc Gastzugang Infrastructu IEEE 802 11n WPAZPersonal  CCMP 1 0 24,00% 8

Total 2 WLANS | 0 WLANS selected

Fig: WLAN overview report

5.4 WLAN Device Details Reports

When you have opened a Windows or Mac OS X computers' Device Details dialog,
select the Networking » WLANs and WLANs Access Points tabs to view

- Wireless networks within range including the signal quality

- Wireless network access points serving the WLANSs in range including the signal
quality and channel numbers

- The active WLAN connection including the connection speed

[D Device Details for 'teetee-pc.frizbox’ o | B |
H-=2@hn0mo|sa

eneral |[Tietwarking || Hardware | Frmware | Software [ user | connections | virtual Computers | custom Attnbutes | Roles | Groups | Analyze|

[ Interfaces | WLANS | WLAN Access Points | Networks | SNV System Group|

Filter:
[ Case sensitive fiiter

ssd Type Physical Type  Auth. Algorithm Cipher Algorithm Connection Mode Receive Speed Transmit Speed Signal Quality [%]  Signal Quality [dBm)
Disc Infrastructure  [EEE802.11n WPA2-Personal ] cawe 20.00% -0
Disc Gestzugang  Infrastructre  IEEE802.11n  WPA2-Personal ] cae 24.00% 88

Total 2 wians | 0 wians selected
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Fig: Device details WLAN report

= | | S|

[ Device Details for 'teetee-pc.fritzbox'

le=2@hOOBGEGE

Interfaces | WLANs| WLAN Access Points | Networks | SNVP System Group|

Filter
|| Case sensitive filter

Name  Model Manufacturer ssid Type Physical Type  Auth. Algorithm Cipher Algorithm  Signal Quality [%]  Signal Quality [dBm]  Channel Number Physical Address
Jisc Infrastructure  IEEE802,1in  WPA2-Personal cavp 20.00% 0 10 c0:25:06:2:ffi0c
DiscGastugang  Infrastucture IEEE802.1in  WPA2Personal cavp 24.00% 8 10 c6:25:08:24:fFioc

<

Total 2 wlan access points | 0 wlan access points selected

Fig: Device details WLAN access points report

5.5 Displaying WLANSs In Topology Maps

JDisc Discovery's topology maps also display WLANSs indicated by a cloud icon (<)
when WLAN clients are connected the WLAN through an access point. WLAN cloud

icons are annotated by the WLAN's SSID.

D New Topology Map

File Layout View Fiter
SE @@ @ Q|55 55 5|7 showwians|[7] Enable comnection hop mit] 31| hops

I

i asab gl
=
3comtest gferanasntot
’
ProCurg1 -, - - B J

. 3
Jbisc |

tom-laptop3.fifz box 1 teetee-peiritz box

\

wwuwy :

Unmanaged Switch ‘|
Hub -
=8

NPI3DD22D frifz.box
€0:25:06:24:7.0¢

Fig: AWLAN in a topology map
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The figure above shows the WLAN 'JDisc' and two connected devices (tom-
laptop3.fritz.box and teetee-pc.fritz.box). In addition to that two access points serving
the 'JDisc' WLAN are also displayed. 'tom-laptop3.fritz.box' is multi-homed and
connected to the 'JDisc' WLAN and to the Ethernet network by an unmanaged switch.

When you select the link between the notebook 'tom-laptop3.fritz.box' and the WLAN
cloud will highlight the connection to the access point to which 'tom-laptop3.fritz.box' is
connected. Selecting the connection between the access point and the 'JDisc' WLAN
will highlight all connections to all clients connected to the access point.
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6 Enhanced Discovery

The Networking Add-On enhances JDisc Discovery's discovery to collect installed
modules of routers and switches.

JDisc Discovery uses the SNMP Entity MIB to collect installed modules. The Hardware
» Modules tab of the Device Details dialog displays installed module.

) Device Details for ProCurvel’ el A |
=2 8hEBE0 R E|lsE

General | Networking‘ Hardware ‘ Firmware | Saoftware | User | Connections | Virtual Computers | Custom Attributes | Roles | Groups | Analyze‘

Processars | Memory Modules | Disks | Modules | video Contraller | Attached Devices|

Filter:
[] Case sensitive filter

Model ° Description Manufacturer Serial Number
ProCurve 187024 24p Gig-T zI Moduls
ProCurve 187024 24p Gig-T zI Module
ProCurve 187024 24p Gig-T zI Moduls
ProCurve 187024 24p Gig-T zI Module
ProCurve 137054 Gig-T/SFP zl Module
ProCurve 187024 24p Gig-T zI Module

] . »

Total 0 modules | 0 modules selected

Close

Figure: Modules of a HP ProCurve Switch
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7/ Open Source

This software includes software developed by various open-source projects and
organizations as listed below. The corresponding files and components are copyright to
the corresponding organization or vendor and all rights reserved. The software files and
components distributed under the open-source licenses are distributed on an "AS IS"
basis, WITHOUT WARRANTY OF ANY KIND, either express or implied. See the
license of the corresponding project for specific rights and limitations under the license.
Depending on the license, any product derived from the products may not be called
with the name of the project nor may the name of the project appear in their name,
without prior written permission. For written permission, please contact the
corresponding project owner by visiting the corresponding project home page as listed
below.

All license files can be found in the installation directory 'Licenses'.

e This product includes software developed by the Apache Foundation
(http://www.apache.org). These are 'Axis', 'Commons Collections', 'Commons
Net', 'CXF', 'log4j', and 'POI', 'Drools', 'log4j'.

e This product includes the 'SBLIM' WBEM implementation
(http://sourceforge.net/projects/sblim/files/sblim-cim-client2/)

e This product includes icons from 'FAMFAMFAM' icon gallery 'SILK'
(http://www.famfamfam.com/lab/icons/silk).

e This product includes Kai Toedter's 'Jcalendar’
(http://www.toedter.com/en/jcalendar/index.html).

e This product includes the JUNG layout library (http://jung.sourceforge.net).

e This product includes the COLT numeric library (http://acs.Ibl.gov/~hoschek/colt).

e This product uses the Postgres database (http://www.postgresqgl.org).
e This product uses SNMP4J (http://www.snmp4j.org).

e This product uses the Ganymed SSH library (http://www.ganymed.ethz.ch/ssh2).
e This product uses the drools rule engine (http:/jboss.org/drools).

e This product uses the janino compiler (http://www.janino.net).

e This product uses Jyhton (http://www.jython.org/Project).

e The product calls the dmidecode binary
(http://www.nongnu.org/dmidecode).
Find the source code in the 'sources' directory.

e This product uses icons from 'Crystal Clear’
(http://commons.wikimedia.org/wiki/Crystal_Clear).

e This product uses the 'PUTTY" ssh client.
e This product uses the dom4j library (http://dom4j.sourceforge.net/dom4j-1.6.1).

e This product uses the Jaxen library (http:/jaxen.org/)
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http://jaxen.org/
http://dom4j.sourceforge.net/dom4j-1.6.1
http://commons.wikimedia.org/wiki/Crystal_Clear
http://www.nongnu.org/dmidecode
http://www.nongnu.org/dmidecode
http://www.jython.org/Project
http://www.janino.net/
http://jboss.org/drools
http://www.snmp4j.org/
http://www.postgresql.org/
http://acs.lbl.gov/~hoschek/colt
http://jung.sourceforge.net/
http://www.toedter.com/en/jcalendar/index.html
http://www.famfamfam.com/lab/icons/silk

This product uses the Jcalendar library (http://toedter.com/jcalendar/).

This product uses the Jdom library (http://www.jdom.org/).

This product uses the saxpath library (http://www.saxpath.org/).

This product uses the miglayout library (http://www.miglayout.com/).
This product uses the taskdialog library (https://code.google.com/p/oxbow/).

This product uses the vijava library (http://vijava.sourceforge.net/).

This product uses the dnsjava library (http://www.dnsjava.org/).

This product uses the trove library (http://trove.starlight-systems.com/).
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